Download button is not working

Post your questions & get help from friendly LibriVoxers
Post Reply
sfreader801
Posts: 2
Joined: December 9th, 2020, 4:43 pm

Post by sfreader801 » December 12th, 2020, 5:21 pm

When I select "Advanced Search" on the main menu and then "Title". I get "Browsing Title" order by "Release Date". I select "Short Science Fiction Collection 073" by pressing
"Download".
Nothing happens. No message at bottom left recognizing any stage of download. No error message from Windows, chrome or librivox. It is like I had done nothing.
I have been downloading books since XP (I think.--It was long ago.) I have been downloading using Windows 10 since it was first issued. This problem has started in the last 3-4 weeks.

TriciaG
LibriVox Admin Team
Posts: 49749
Joined: June 15th, 2008, 10:30 pm
Location: Toronto, ON (but Minnesotan to age 32)

Post by TriciaG » December 12th, 2020, 5:26 pm

Hmm. It works for me. It pops up a window asking me where I want to save the Zip file. What happens if you right click on the Download button and select "Save Link As"?
We're MARCHing to the finish line! Join our project cleanup month initiative. Details HERE

mightyfelix
LibriVox Admin Team
Posts: 7546
Joined: August 7th, 2016, 6:39 pm

Post by mightyfelix » December 12th, 2020, 6:53 pm

I'm actually getting the same thing. No download, no popup window, nothing. However, I did try one thing that worked. Try this: Instead of left-clicking on the Download button, right-click it and then select "Open link in new tab". That started the download going for me. Maybe it will help you?

mightyfelix
LibriVox Admin Team
Posts: 7546
Joined: August 7th, 2016, 6:39 pm

Post by mightyfelix » December 12th, 2020, 6:53 pm

TriciaG wrote:
December 12th, 2020, 5:26 pm
Hmm. It works for me. It pops up a window asking me where I want to save the Zip file. What happens if you right click on the Download button and select "Save Link As"?
What browser are you using? It might be something to do with Chrome.

TriciaG
LibriVox Admin Team
Posts: 49749
Joined: June 15th, 2008, 10:30 pm
Location: Toronto, ON (but Minnesotan to age 32)

Post by TriciaG » December 12th, 2020, 6:55 pm

I'm on Waterfox (a fork of Firefox).
We're MARCHing to the finish line! Join our project cleanup month initiative. Details HERE

sfreader801
Posts: 2
Joined: December 9th, 2020, 4:43 pm

Post by sfreader801 » December 12th, 2020, 7:26 pm

Thanks triciag and mightyfelix both of your solutions give downloads. But I still can't do it the old way. Maybe it has something to do with chrome or (i forgot to note) bitdefender. I'll post it if I find the solution.

Post Reply