Uploading

Post your questions & get help from friendly LibriVoxers
Post Reply
Yanchik
Posts: 2
Joined: May 15th, 2020, 1:39 am

Post by Yanchik » June 14th, 2020, 12:35 am

Hi there,
I’ve tried to upload my book and got "SyntaxError: JSON Parse error: Unrecognized token ‘<‘" error. Also I’ve got IOS system.
What should I do?

Thank you

annise
LibriVox Admin Team
Posts: 32963
Joined: April 3rd, 2008, 3:55 am
Location: Melbourne,Australia

Post by annise » June 14th, 2020, 12:55 am

What book are you talking about and what format is it in?
Our uploaded has size and format limitations. Let's know and someone will probaly be able to help.

Anne
It's also possible that your filename has Russian characters and our and Archives software can have trouble with them
Unless it is your one minute test , you can't upload things until there is a project set up and you know what folder to use and what the file label is for that project

tovarisch
Posts: 2906
Joined: February 24th, 2013, 7:14 am
Location: New Hampshire, USA

Post by tovarisch » June 14th, 2020, 4:44 am

Yanchik wrote:
June 14th, 2020, 12:35 am
I’ve tried to upload my book and got "SyntaxError: JSON Parse error: Unrecognized token ‘<‘" error. Also I’ve got IOS system.
What should I do?
What "book" would it be? I see this was your second post. Have you completed the 1-minute test? I think the Welcome e-mail is supposed to give you the instructions, and if you missed that, there is the wiki page that talks about it.

It is possible you are confused with how things are done in LibriVox. It is generally advised to acquaint oneself with the (reasonably simple) process that exists. It does exist. And the reason is that it makes things easier, like when you put your trousers on, you don't start with buckling your belt...

What's IOS system? Do you mean you're trying to upload from an iPhone? That is not likely to work. It's OK to do from a Mac or PC, but it's just a bit more involved than texting.

Start by reading the Wiki and the Welcome e-mail, and asking specific questions before you do anything else, just to clarify stuff for yourself.

P.S. If you think you might understand all this better in Russian, let us know, we can certainly communicate using Russian/Cyrillic, the forums allow that and there are several experienced enough members who speak Russian to help you.
tovarisch
  • reality prompts me to scale down my reading, sorry to say
    to PLers: do correct my pronunciation please

TriciaG
LibriVox Admin Team
Posts: 46343
Joined: June 15th, 2008, 10:30 pm
Location: Toronto, ON (but Minnesotan to age 32)

Post by TriciaG » June 14th, 2020, 6:16 am

Two things to try, after checking to be sure the file name doesn't contain any disallowed characters:

1) Refresh the uploader page to make absolutely sure that you are logged in, and upload again. This error can occur when you have become logged out unbeknown to you.

2) Try removing any ID3 tags / metadata.
Hatfields & McCoys Sensationalist Account: An American Vendetta
Humor: Maxims of Methuselah about women

Post Reply