Does a Smart Tablet make noise?

Post your questions & get help from friendly LibriVoxers
GrayHouse
Posts: 507
Joined: October 6th, 2012, 3:27 pm

Post by GrayHouse » August 27th, 2014, 10:24 am

I've experimented without much luck - Android is way behind the competition when it comes to USB audio.
If you're getting otherwise decent audio from the Yeti then you're almost there. Try the obvious things like moving between rooms to see if it varies environmentally. I wonder if the tablet is struggling to supply adequate power. It may be worth trying a powered USB hub to confirm/rule out that possibility.

tovarisch
Posts: 2933
Joined: February 24th, 2013, 7:14 am
Location: New Hampshire, USA

Post by tovarisch » August 27th, 2014, 11:16 am

Not entirely on the same topic, but I've thought about using a tablet to read, if recording is actually done by a portable recorder, like TASCAM's DR-05. Of course that means that after preparing the text I'd need to copy it to the tablet, and the editing still needs to be done elsewhere, so it's somewhat problematic/complicated as a process.

Currently when I edit I do have the ability to re-record pieces since I use the same computer for everything... I am also contemplating trying my [a few years old] notebook computer again. I've replaced the hard drive in it with an SSD, so hopefully it produces significantly less noise. Still, there is a question whether its fan is going to start during recording. But that's a different subject altogether :?
tovarisch
  • reality prompts me to scale down my reading, sorry to say
    to PLers: do correct my pronunciation please

Cori
LibriVox Admin Team
Posts: 12167
Joined: November 22nd, 2005, 10:22 am
Location: Britain
Contact:

Post by Cori » August 27th, 2014, 11:56 am

tovarisch wrote:I've thought about using a tablet to read, if recording is actually done by a portable recorder, like TASCAM's DR-05. Of course that means that after preparing the text I'd need to copy it to the tablet, and the editing still needs to be done elsewhere, so it's somewhat problematic/complicated as a process.
This is what I do, more or less. :D Copying to the tablet isn't a problem because it has wireless, so it's quite easy to put the file in a shared folder on my networked PC that the tablet can access. (Note, it's easy on Android and impossible as far as I can tell on a Windows Mobile device. Go figure!) I record from a microphone that has a long cable out of my recording area to the laptop. It is a permanent set-up, so I don't tend to have major sound differences between takes.
There's honestly no such thing as a stupid question -- but I'm afraid I can't rule out giving a stupid answer : : To Posterity and Beyond!

Slithy
Posts: 73
Joined: January 13th, 2011, 11:41 pm

Post by Slithy » August 27th, 2014, 12:32 pm

GrayHouse wrote:I've experimented without much luck - Android is way behind the competition when it comes to USB audio.
If you're getting otherwise decent audio from the Yeti then you're almost there. Try the obvious things like moving between rooms to see if it varies environmentally. I wonder if the tablet is struggling to supply adequate power. It may be worth trying a powered USB hub to confirm/rule out that possibility.
Thank you for the reply!

I had not considered whether the need for external power could be associated with the noise, would i be better off using my current usb to micro usb and adding a powered hub or looking for a hub that handles the host otg micro usb stuff too?

I did try changing rooms, and I am pretty sure the noise is not environmental. The edited audio quality is much better than when recording at my desktop(I previously had issues with the combination of volume increases and multiple noise cleanings turning my voice robotic), though I really dislike the hum itself.

Thanks again for your help.
Cori wrote: :D Copying to the tablet isn't a problem because it has wireless, so it's quite easy to put the file in a shared folder on my networked PC that the tablet can access..
Even without the use of a shared network folder, Android tablets tend to be pretty easy to move files onto. The 3 that I have owned all connected like flashdrives to windows that you could put files onto with the usb cable and even without a cable you can use an app like "Airdroid" to use wifi to connect the file system.

RuthieG
Posts: 22011
Joined: April 17th, 2008, 8:41 am
Location: Kent, England
Contact:

Post by RuthieG » August 27th, 2014, 12:40 pm

I know nothing about tablets, but have you looked to see at what frequency the hum is? This may a) give you a clue to the cause, and b) if it is at one frequency only, mean it is easy to remove while leaving your voice virtually untouched (using Notch Filter with a high Q value).

Ruth
My LV catalogue page | RuthieG's CataBlog of recordings | Tweet: @RuthGolding

Slithy
Posts: 73
Joined: January 13th, 2011, 11:41 pm

Post by Slithy » August 27th, 2014, 12:52 pm

RuthieG wrote:I know nothing about tablets, but have you looked to see at what frequency the hum is? This may a) give you a clue to the cause, and b) if it is at one frequency only, mean it is easy to remove while leaving your voice virtually untouched (using Notch Filter with a high Q value).

Ruth
I'm honestly not even sure if the sound would be properly described as a hum, but I'm interested in anything that could help clean it up. How would I be able to isolate the frequency and would you have any advice to supplement the information from http://manual.audacityteam.org/o/man/notch_filter.html ?

Thank you for your help!

RuthieG
Posts: 22011
Joined: April 17th, 2008, 8:41 am
Location: Kent, England
Contact:

Post by RuthieG » August 27th, 2014, 1:05 pm

Instructions for how to identify the frequency are here: http://wiki.librivox.org/index.php/Removing_Mains_Hum

But if you'd like to upload a sample to the tests folder, I will happily take a look. Let's see what the noise looks like before going into Notch Filter. It may not be what you need.

Ruth
My LV catalogue page | RuthieG's CataBlog of recordings | Tweet: @RuthGolding

Slithy
Posts: 73
Joined: January 13th, 2011, 11:41 pm

Post by Slithy » August 27th, 2014, 1:15 pm

RuthieG wrote:Instructions for how to identify the frequency are here: http://wiki.librivox.org/index.php/Removing_Mains_Hum

But if you'd like to upload a sample to the tests folder, I will happily take a look. Let's see what the noise looks like before going into Notch Filter. It may not be what you need.

Ruth
I will attempt to get a good sound sample for you. Would you prefer one entirely unedited or volume increased to the librivox standard(I believe this makes the noise more apparent)?

Thank you again for your help with this!

edit: I went ahead and uploaded it without editing(beyond making the stereo sound mono - which the tablet program defaults to annoyingly)
https://librivox.org/uploads/tests/uneditted_hum_test_slithy.mp3

When i tried to follow the Mains Hum page I believe i was finding a peak of around 28-29Hz (Sampled a couple different spots) - but I might be finding the wrong peak.

Also, on the subject of what is causing it - I've noticed that changing the gain on the microphone did not impact the volume of the hum itself.

tovarisch
Posts: 2933
Joined: February 24th, 2013, 7:14 am
Location: New Hampshire, USA

Post by tovarisch » August 27th, 2014, 2:32 pm

Thanks for the test recording. I managed to clean out the most of the whiny high-frequency noise from it by applying the notch filter four times: at 1000, 2000, 3000, and 4000 Hertz, with Q (width) set to '20' (narrowest). Also, your volume is way too low, but you probably know that.

I amplified the entire track for the suggested 12.4 to try to hear the noise (which I did), then I found a piece without the clicking, paper rustling, breathing, at the end of the track, and amplified it more (~20) to see those spikes on the spectrum plot. After that it was just guessing that the notch filter should remove those things.

Another (quicker, but less effective) way is to do the low pass filter on the entire track, but that also changes the result by dulling your recording somewhat.

Hope this helps!
tovarisch
  • reality prompts me to scale down my reading, sorry to say
    to PLers: do correct my pronunciation please

Slithy
Posts: 73
Joined: January 13th, 2011, 11:41 pm

Post by Slithy » August 27th, 2014, 2:44 pm

tovarisch wrote:Thanks for the test recording. I managed to clean out the most of the whiny high-frequency noise from it by applying the notch filter four times: at 1000, 2000, 3000, and 4000 Hertz, with Q (width) set to '20' (narrowest). Also, your volume is way too low, but you probably know that.

I amplified the entire track for the suggested 12.4 to try to hear the noise (which I did), then I found a piece without the clicking, paper rustling, breathing, at the end of the track, and amplified it more (~20) to see those spikes on the spectrum plot. After that it was just guessing that the notch filter should remove those things.

Another (quicker, but less effective) way is to do the low pass filter on the entire track, but that also changes the result by dulling your recording somewhat.

Hope this helps!
Wow, that is quite a bit of information! I will attempt to reproduce what you did and see what the results are like. The frequency is much higher than i expected.

The gain was quite low due to it not impacting the hum volume, but I hope that if Notch filter does the trick(and after my pop filter comes in) I can find a gain level that minimizes the need for amplification.

Thank you very much for your help! If i can get portable recording going smoothly then it would make my life much easier for getting moderately clean recordings!

RuthieG
Posts: 22011
Joined: April 17th, 2008, 8:41 am
Location: Kent, England
Contact:

Post by RuthieG » August 28th, 2014, 12:20 am

Precisely what I found. Audibly I could hear a high-pitched whine. Visually I saw a series of peaks at roughly (but not exactly) 1000 Hz intervals. Although they were all at a low deciBel level, they are definitely what is causing the whine. It was hard to see until I changed my settings on Analyze | Spectrum like this:

Image

Yes, the whine can be removed using Notch filter several times, and perhaps a Low Pass Filter at 7000+ Hz. But the question is, what is causing it? I really have no idea :?.

Ruth
My LV catalogue page | RuthieG's CataBlog of recordings | Tweet: @RuthGolding

GrayHouse
Posts: 507
Joined: October 6th, 2012, 3:27 pm

Post by GrayHouse » August 28th, 2014, 10:58 am

Thanks for the sample, it makes things much easier - scrap my earlier idea about insufficient power.
As others have said, it's a 1kHz frequency (which also shows up as harmonics). It's precise and constant which means that it's almost certainly coming from the USB (1kHz is a key sync frequency for USB).

My guess is that the OTG cable isn't well shielded and it's picking up some of this signal, probably in the ground wire, which is then radiating inside the Yeti and getting in to the mic preamp. So I think it's all down to the quality of the cables and connectors. With OTG there isn't a massive choice; the ones that I've seen are distinctly low quality. I'm not sure what combination of cables you're using - if it's an OTG adaptor AND a regular USB cable plugged together, you could try changing the USB cable to a decent quality shielded one. Also, generally, prefer short cables to longer ones. But, tbh, I don't think that's going to really cure it.

If you happen to have a USB powered hub laying around (or can borrow one) that may still be worth a go if the noise is being radiated up the cable in the power wires (within the USB cable).

Best,

-Ian
Last edited by GrayHouse on August 28th, 2014, 1:39 pm, edited 1 time in total.

RuthieG
Posts: 22011
Joined: April 17th, 2008, 8:41 am
Location: Kent, England
Contact:

Post by RuthieG » August 28th, 2014, 12:37 pm

it's almost certainly coming from the USB (1kHz is a key sync frequency for USB).
Now that is really interesting. Thank you, Grayhouse!

Ruth
My LV catalogue page | RuthieG's CataBlog of recordings | Tweet: @RuthGolding

Slithy
Posts: 73
Joined: January 13th, 2011, 11:41 pm

Post by Slithy » August 28th, 2014, 2:05 pm

GrayHouse wrote:Thanks for the sample, it makes things much easier - scrap my earlier idea about insufficient power.
As others have said, it's a 1kHz frequency (which also shows up as harmonics). It's precise and constant which means that it's almost certainly coming from the USB (1kHz is a key sync frequency for USB).

My guess is that the OTG cable isn't well shielded and it's picking up some of this signal, probably in the ground wire, which is then radiating inside the Yeti and getting in to the mic preamp. So I think it's all down to the quality of the cables and connectors. With OTG there isn't a massive choice; the ones that I've seen are distinctly low quality. I'm not sure what combination of cables you're using - if it's an OTG adaptor AND a regular USB cable plugged together, you could try changing the USB cable to a decent quality shielded one. Also, generally, prefer short cables to longer ones. But, tbh, I don't think that's going to really cure it.

If you happen to have a USB powered hub laying around (or can borrow one) that may still be worth a go if the noise is being radiated up the cable in the power wires (within the USB cable).

Best,

-Ian
USB being behind it really makes a lot of sense. I'm using the USB cable that came with the Yeti itself combined with a low end OTG. Are there any keywords that would help me hunt down shielded products?

Thanks for your technical help with this!

GrayHouse
Posts: 507
Joined: October 6th, 2012, 3:27 pm

Post by GrayHouse » August 28th, 2014, 3:18 pm

Slithy wrote:USB being behind it really makes a lot of sense. I'm using the USB cable that came with the Yeti itself combined with a low end OTG. Are there any keywords that would help me hunt down shielded products?
I don't think you'll find one. I've just cut open my own OTG adaptor to marvel at its poor construction. I'm guessing yours is similar - 30(?) pin edge connector with about 3 inches of cheap cable connecting to a USB A socket.

I'm very diy-inclined, so my approach would be to try to shield this one - the problem would be opening the 30 pin edge connector to make a connection to the outer metal casing. It's a lot of effort for a result that's not guaranteed...

Post Reply