The all-new "HELP! I have an Audacity problem" thread

Post your questions & get help from friendly LibriVoxers
philchenevert
LibriVox Admin Team
Posts: 17773
Joined: October 17th, 2010, 9:23 pm
Location: With my feet in the Bayou
Contact:

Post by philchenevert » June 12th, 2012, 2:16 pm

TriciaG wrote:Shift-Arrow increases in the direction of the arrow.

I just discovered by experimentation that Control-Shift-Arrow decreases in the direction of the arrow. Example: You have a highlighted section between time stamps 0:07 and 0:08. Ctrl-Shift-Right Arrow decreases from the side closest to the 0:07 mark.

8-)
YES! thanks Tricia. Now I will see if I can program the keys into something more finger friendly and I am all set up to save my poor hand muscles! this is great. another small step for mankind. Image

EDIT: yep, it was a simple matter of changing the keyboard shortcut to D and now it works smooth as a baby's behind. !cool
Phil Chenevert, The LibriVox Video Guy

Remember to boil the internet for at least 5 minutes before and after using it. Can't be too safe.


These Tutorial Videos Certified Virus Free !!

Violynne
Posts: 2
Joined: June 20th, 2012, 9:00 am

Post by Violynne » June 21st, 2012, 3:04 pm

Hi,
Just wondering...how to set Audacity to "mono"?

TriciaG
LibriVox Admin Team
Posts: 44841
Joined: June 15th, 2008, 10:30 pm
Location: Toronto, ON (but Minnesotan to age 32)

Post by TriciaG » June 21st, 2012, 3:11 pm

To change all future recordings, go to Edit, Preferences, Devices. Under Recording, change Channels to "1 (Mono)".
Mystery stories: The Master of Mysteries
Mussolini's speeches thru 1923: LINK
Samuel Smiles Self-Help: Character
Family history: The Medici, Vol. 2

Hokuspokus
LibriVox Admin Team
Posts: 8021
Joined: October 24th, 2007, 12:17 pm
Location: Germany
Contact:

Post by Hokuspokus » June 27th, 2012, 8:13 am

Something strange happened to my Audacity:

Image

Darker grey areas at the top and the bottom, blue lines and one can effect the volume with them, too. Must have happened while I struggled with the caps lock key (my secret enemy).

Can someone please tell me how I get back to normal?

philchenevert
LibriVox Admin Team
Posts: 17773
Joined: October 17th, 2010, 9:23 pm
Location: With my feet in the Bayou
Contact:

Post by philchenevert » June 27th, 2012, 8:27 am

It looks like you have the Envelop tool turned on (one of those 6 tools at the top). It is used to reduce the volume on tracks, usually music tracks under vocal tracks. Just click on the Selection tool, the I beam one.

Or maybe not. Also if you fight with the caps lock key like me, I have found that I can 'suspend' my autohot keys to get control of it again.
Phil Chenevert, The LibriVox Video Guy

Remember to boil the internet for at least 5 minutes before and after using it. Can't be too safe.


These Tutorial Videos Certified Virus Free !!

Piotrek81
Posts: 3665
Joined: November 3rd, 2011, 2:02 pm
Location: Poznań, Poland

Post by Piotrek81 » June 27th, 2012, 8:29 am

To me it looks like you inadvertently activated the "envelope" function. Try going to "edit" and then "undo" .That's what usually works for me in such cases. Unless you've already done more actions in the meantime, in which case I'm not sure how to help.
Come help us record The Deluge THE DELUGE IS BACK!
Want to hear some PREPARATION TIPS before you press "record"? Listen to THIS and THIS

Hokuspokus
LibriVox Admin Team
Posts: 8021
Joined: October 24th, 2007, 12:17 pm
Location: Germany
Contact:

Post by Hokuspokus » June 27th, 2012, 8:34 am

Ah! :idea:

Thank you, Phil. That did the trick. And of course it was the autohotkey.

Thank you, Piotrek. "Undo" was the first thing I tried. And then I run out of ideas ...

peac
Posts: 367
Joined: November 1st, 2008, 9:47 pm
Location: California
Contact:

Post by peac » June 28th, 2012, 10:08 am

I've been working on some long recordings recently (30+ minutes) and have been having incredibly long response times when I come back to edit - if I edit in the same session it doesn't seem as bad, but if I close the project and then come back later it can take minutes for Audacity to recover if I delete anything (no matter how small). The only thing I've found that helps is to export as an mp3 when I'm done editing and then import the mp3 into a new project when I come back to edit again.

Any suggestions on how to improve performance so I can edit the original project?

Is there any significant degradation to the recording when I use the export/import method? (I don't hear any difference so far, but it does mean that the final recording is several generations removed from the original and I'm afraid that's going to catch up with me sooner or later.)
John Andrew Holmes: "It is well to remember that the entire universe, with one trifling exception, is composed of others."

TriciaG
LibriVox Admin Team
Posts: 44841
Joined: June 15th, 2008, 10:30 pm
Location: Toronto, ON (but Minnesotan to age 32)

Post by TriciaG » June 28th, 2012, 10:13 am

Do you have other programs closed when editing? Do you have enough RAM?

I would suggest exporting/importing with FLAC rather than MP3. FLAC is lossless.
Mystery stories: The Master of Mysteries
Mussolini's speeches thru 1923: LINK
Samuel Smiles Self-Help: Character
Family history: The Medici, Vol. 2

Cori
LibriVox Admin Team
Posts: 12178
Joined: November 22nd, 2005, 10:22 am
Location: Britain
Contact:

Post by Cori » June 28th, 2012, 10:17 am

peac wrote:Is there any significant degradation to the recording when I use the export/import method? (I don't hear any difference so far, but it does mean that the final recording is several generations removed from the original and I'm afraid that's going to catch up with me sooner or later.)
Depends on the quality of your original input. I played with this a few years ago -- here are my results then:

viewtopic.php?f=23&t=9084
There's honestly no such thing as a stupid question -- but I'm afraid I can't rule out giving a stupid answer : : To Posterity and Beyond!

peac
Posts: 367
Joined: November 1st, 2008, 9:47 pm
Location: California
Contact:

Post by peac » June 28th, 2012, 10:24 am

I edit once to get rid of all the re-tries and throat-clearings and a second time for acuracy. When I'm doing the second pass Firefox is open also, but generally that's it.

How much is enough RAM? :) I think I have plenty, but if there's a guideline let me know.

I will try FLAC. Sounds like it's a safer way to go.
John Andrew Holmes: "It is well to remember that the entire universe, with one trifling exception, is composed of others."

TriciaG
LibriVox Admin Team
Posts: 44841
Joined: June 15th, 2008, 10:30 pm
Location: Toronto, ON (but Minnesotan to age 32)

Post by TriciaG » June 28th, 2012, 10:35 am

I don't know - how much RAM do you have? :lol:

My old laptop had 2 GB, and I would occasionally have problems with skipping and stuff with Audacity, but not with it hesitating like you're describing. My newer laptop has 4 GB, so I'm pretty well set. 8-)

Firefox can be a memory hog, too. If you don't close it once in a while, you might want to do that to clear some of the memory it uses before editing. (And reopen it to see your text, of course.)
Mystery stories: The Master of Mysteries
Mussolini's speeches thru 1923: LINK
Samuel Smiles Self-Help: Character
Family history: The Medici, Vol. 2

philchenevert
LibriVox Admin Team
Posts: 17773
Joined: October 17th, 2010, 9:23 pm
Location: With my feet in the Bayou
Contact:

Post by philchenevert » June 28th, 2012, 11:14 am

I save my recordings as I go along as .aup, the native Audacity file type. This is so fast (a contrl+s) I can save every time I stop for anything thus my save file is almost always up to date and if an electrical outage occurs, nothing is lost.

When opening an .aup file that has been closed, it opens significantly more quickly for me than an MP3. it is my belief that the .aup files are a form of losless data storage but I have no proof of this. So working with the .aup file, editing, making changes, etc. seems to avoid the lag and stuttering that I've experienced when opening and working with MP3 files. Not often, but it has happened. Only when the file is completely edited and ready for export do I make an MP3.

yeah, I know this is not the normal procedure for most people who save FLAC and are more cautious but I have never lost any .aup files (except for the time I stored it in the wrong place and it took a week to find it) and they just seem so much quicker to work with that it is my normal procedure. Of course the .aup file has two parts, the .aup and the data file which must be in the same folder. This is automatic but if you should move one, it won't be found until you move them both into the same folder. Long post to just suggest working with .aup and see if it loads more quickly. Image
Phil Chenevert, The LibriVox Video Guy

Remember to boil the internet for at least 5 minutes before and after using it. Can't be too safe.


These Tutorial Videos Certified Virus Free !!

peac
Posts: 367
Joined: November 1st, 2008, 9:47 pm
Location: California
Contact:

Post by peac » June 28th, 2012, 11:43 am

Um, thank you, Phil. Unfortunately using the native .aup files is what I normally do. I agree that that's by far the easiest and fastest way - usually. Unfortunately that hasn't been the case with these bigger files.

As I've been thinking about this I doubt that RAM is the problem. I suspect that the reason editing just-recorded and unsaved files is quick is because the recording is still (at least mostly) in RAM. I'm wondering if the issue is that Audacity's disk IO is slow for larger files and if it's writing every edit to disk and then retrieving the newly saved version back from disk again. I will have to play with the options to see if there's some way to force Audacity to load and edit in RAM, and see if that makes any difference.
John Andrew Holmes: "It is well to remember that the entire universe, with one trifling exception, is composed of others."

philchenevert
LibriVox Admin Team
Posts: 17773
Joined: October 17th, 2010, 9:23 pm
Location: With my feet in the Bayou
Contact:

Post by philchenevert » June 28th, 2012, 11:54 am

Well, it it didn't help, at least I know that I'm not the only person using the .aup files. Sometimes it gets lonely.

and RAM may have a lot to do with it, but I don't know how to make Audacity use it. I will load a big file and see what happens.
Phil Chenevert, The LibriVox Video Guy

Remember to boil the internet for at least 5 minutes before and after using it. Can't be too safe.


These Tutorial Videos Certified Virus Free !!

Post Reply