The all-new "HELP! I have an Audacity problem" thread

Post your questions & get help from friendly LibriVoxers
plaidsicle
Posts: 736
Joined: December 17th, 2014, 10:57 pm
Location: Indiana, USA
Contact:

Post by plaidsicle » August 26th, 2018, 10:33 am

tovarisch wrote:
August 25th, 2018, 2:04 pm
Closing what you don't need or don't intend to use should definitely help. I see that you're forced to look up certain words while recording. You can pause the recording for that, just don't forget to un-pause afterwards.

I think you could try to fix the recording using a compressor effect. It's not going to be the same quality as it didn't happen, but it will bring up the parts with diminishing levels up.
that reminds me of another weird Audacity thing I've noticed-- whenever I did pause and re-start the recording for some reason, the newer section would usually always seem to fade in, like it had to catch up to a normal volume or something. so I stopped doing that and just edited out all the long mess-up sections.

we'll see if the compressor effect helps or if I just need to re-record..
'whenever people agree with me I always feel I must be wrong.' -Oscar Wilde
plaidsicle.blogspot.com

lpeders
Posts: 29
Joined: September 7th, 2018, 5:56 pm

Post by lpeders » September 21st, 2018, 5:28 pm

Calling Audacity specialists :help:
I am new here on LibriVox and have only just started recording with Audacity in the past couple of weeks. I have completed my 1 minute test and was approved to participate. I have read one weekly poem and received positive feedback. Now I am working on Love Songs in poetry and I have identified a problem that I can't solve. :?
My audio is being truncated, clipped, or dropped somehow. I'm not yet sure of the right lingo to be using here. Words are being chopped and silences eliminated so that a natural pause sounds unnatural. I have checked that "truncate silence" has not been adjusted from factory settings. I updated to the Audacity 2.2.2 to see if it got better but it didn't. I've turned off "detect dropouts" and I'm still experiencing this clipping. I'm wondering if my hardware is not keeping up with the software? Or maybe my microphone isn't keeping up? I would appreciate any tips for troubleshooting! Thanks!
Lauren

tovarisch
Posts: 2579
Joined: February 24th, 2013, 7:14 am
Location: New Hampshire, USA

Post by tovarisch » September 21st, 2018, 5:43 pm

I am no specialist, and can only recommend looking in a couple of additional places. One is "voice activated recording", it sometimes can start late and/or finish early (according to my understanding). Do you have built-in noise canceling? If you do, it can sometimes behave aggressively enough so the endings are muted. Can you record a small piece to demo what you're talking about? Export as MP3 and post in 'tests-tests' (like the 1-minute you did) and then reply here with a link. You can also start a new thread in this forum if you want. I do suspect that your problem is not with Audacity.

BTW, can you also post the details of your hardware/software setup? I mean, what mic, what OS, and if you have a special interface...
tovarisch
  • reality prompts me to scale down my reading, sorry to say
    to PLers: do correct my pronunciation please

Kitty
LibriVox Admin Team
Posts: 14289
Joined: March 28th, 2014, 5:57 am

Post by Kitty » September 22nd, 2018, 12:43 am

lpeders wrote:
September 21st, 2018, 5:28 pm
My audio is being truncated, clipped, or dropped somehow. I'm not yet sure of the right lingo to be using here. Words are being chopped and silences eliminated so that a natural pause sounds unnatural. I have checked that "truncate silence" has not been adjusted from factory settings. I updated to the Audacity 2.2.2 to see if it got better but it didn't. I've turned off "detect dropouts" and I'm still experiencing this clipping.
Tovarisch is right, it might be sound-activated recording that is turned on. Do the cuttings mainly happen at the beginnings ?

Could you check the following setting in Audacity:

> go to Edit (in the upper tool bar)
> go to Preferences (at the bottom of the list)
> select Recording in the left-side menu
> is the box with "Sound Activated Recording" ticked ? If so, untick it.
> press OK

Let's hope this solves the problem. If not, maybe you indeed have the same function on your microphone, and need to turn it off there too.

Sonia

annise
LibriVox Admin Team
Posts: 29995
Joined: April 3rd, 2008, 3:55 am
Location: Melbourne,Australia

Post by annise » September 22nd, 2018, 4:21 am

Another possibility could be you are running out of resources. Audacity uses lots of memory and processor time as you are recording, and if you are short it will try to keep going by leaving bits out. So it's worth checking if something is running in the background or you could free some resources somewhere.

Anne

JayKitty76
Posts: 508
Joined: August 3rd, 2018, 3:16 pm
Location: In a galaxy far, far away...
Contact:

Post by JayKitty76 » September 22nd, 2018, 8:20 am

If you are using Amplify in Audacity, the box marked ‘Allow clipping’ may be checked. Try unchecking it and see if that helps. This will only work if you are using Amplify, though.
~JayKitty76

lpeders
Posts: 29
Joined: September 7th, 2018, 5:56 pm

Post by lpeders » September 22nd, 2018, 8:53 am

Thank you torvarisch, kitty, annise, and jaykitty76 for your suggestions. Here is a clip with my indicated problem occurring at approximately 0:01.5 in the 0:13 recording. I said "Hello LibriVox forum participant" and what you hear is "Hello LibriVox for participant".

https://librivox.org/uploads/tests/truncatingtest_lpeders.mp3

To respond to your comments and suggestions - I am not using voice actived recording. I am using an Insignia model NS-PAUM50 (since I'm just getting started here I haven't invested in good equipment and maybe that's my problem!), Windows 10, and Audacity 2.2.2. And it does seem that the problem occurrs primarily in the first 2 seconds of recordings. So, maybe I just need to record two seconds of junk commentary at the beginning of my recordings and then trim them out of the file to be used?

Thanks for your time! I really do appreciate the help, I want to learn and do my best for these projects!
Lauren

tovarisch
Posts: 2579
Joined: February 24th, 2013, 7:14 am
Location: New Hampshire, USA

Post by tovarisch » September 22nd, 2018, 10:22 am

Thanks, Lauren, for the sample. I am unfamiliar with NS-PAUM50's performance, and I did look it up on the 'net just to see what kind it was. Usually the driver for the recording device would be responsible for collecting the samples and transferring them to the program (like Audacity). It is possible that due to a bug in the driver (which is itself a piece of software), they lose some samples around 1.5 seconds from the start of the recording. Keep your eye on a newer version of the driver. If Insignia has a web site, perhaps they have a forum in which malfunctions like yours are discussed: if it's a bug, somebody must have stumbled on it as well.

If you see this behavior consistently, you've found a great work-around for this problem: let the microphone record for two seconds before starting what you want stored by Audacity. Then you can easily cut away the beginning in the post-production steps.
tovarisch
  • reality prompts me to scale down my reading, sorry to say
    to PLers: do correct my pronunciation please

DaveWindell
Posts: 30
Joined: October 10th, 2018, 7:53 am

Post by DaveWindell » October 11th, 2018, 2:04 am

Hi to all. I am DaveWindell a newbie and not at all tech savvy. (I have just posted my question in the wrong thread just to show what a dim-wit I can be). I have a Marantz USB microphone, which I'm told is ok for recording, but on Audacity I have to turn the 'recording volume' up to 100% otherwise the playback is very quiet. Is this normal or have I set up the microphone or the software wrongly? All and any advice gratefully received! Thanks, DaveWindell

Kitty
LibriVox Admin Team
Posts: 14289
Joined: March 28th, 2014, 5:57 am

Post by Kitty » October 11th, 2018, 2:37 am

DaveWindell wrote:
October 11th, 2018, 2:04 am
Hi to all. I am DaveWindell a newbie and not at all tech savvy. (I have just posted my question in the wrong thread just to show what a dim-wit I can be). I have a Marantz USB microphone, which I'm told is ok for recording, but on Audacity I have to turn the 'recording volume' up to 100% otherwise the playback is very quiet. Is this normal or have I set up the microphone or the software wrongly? All and any advice gratefully received! Thanks, DaveWindell
I also have my Audacity input volume (the slider bar next to the microphone icon) set all the way up to 100%. If the sound is normal then, why not ? That's why it's there for. :) Maybe you have a toggle on your microphone to set the input volume higher, but it's not necessary. How soft is your recording ? If you set it 100% is it still too soft ?

Also are you using Windows 10 ? I have heard that other users had problems with lower sound since the upgrade :?

In any case, you can easily amplify with Audacity, if the volume is still too soft recorded.
We have a handy plug-in to assess the volume to get to the desired 89 dB.
Replay Gain plugin for Audacity: - http://forum.audacityteam.org/download/file.php?id=4668

1. Save the file to your computer - your desktop or somewhere where you can easily find it.
2. Now browse to the folder in which Audacity is installed. It's probably in C:\Program Files\Audacity) and then open the Plug-Ins folder.
3. Drag the file you saved into the Plug-Ins folder.
4. When next you start up Audacity, you will be able to select the whole recording (Ctrl+A on Windows), then go to Analyze | ReplayGain, and it'll tell you how much to amplify your file to get to about 89 dB.
Then try this:

> highlight your recording
> go to Effect
> go to Amplify
> input the number Replay Gain gave you in the first slot (amplification dB) to increase the volume
> press ok

That should do the trick. :)

And as to "dim-wit", I disagree...it takes wit and courage to notice you own errors, admit them and try to change them. :thumbs: And asking questions is never wrong.

Sonia

DaveWindell
Posts: 30
Joined: October 10th, 2018, 7:53 am

Post by DaveWindell » October 11th, 2018, 4:35 am

Thanks so much for the advice. At 100% record volume it's fine but I'll use the 'plug-in to check and I'll sort out the 'amplify' setting as well.Thanks a lot! :clap:

silverquill
Posts: 7817
Joined: May 25th, 2013, 9:11 pm
Location: Pittsfield, New Hampshire USA

Post by silverquill » October 13th, 2018, 7:49 am

ERROR OPENING AUDIO DEVICE

Yikes! I cannot open Audacity at all.
I've restarted Windows 10.
I've uninstalled Audacity and installed the newest version 2.3.0

I'm dead in the water if I can't get this fixed.

tovarisch
Posts: 2579
Joined: February 24th, 2013, 7:14 am
Location: New Hampshire, USA

Post by tovarisch » October 13th, 2018, 7:56 am

It's possible that it's not Audacity that is to blame.

Go to your Windows Sound settings and see if anything needs to be addressed there. Start -> Settings -> System -> Sound, look if there is anything that is out of the ordinary. Try "Troubleshoot" buttons.

Is there another application (like Skype) that you use for getting sound into your computer? Do you have "Cortana" enabled? If yes, can it "hear" you?
tovarisch
  • reality prompts me to scale down my reading, sorry to say
    to PLers: do correct my pronunciation please

Cori
LibriVox Admin Team
Posts: 12042
Joined: November 22nd, 2005, 10:22 am
Location: Great Britain
Contact:

Post by Cori » October 13th, 2018, 8:00 am

If that doesn't help, then you could work through the options here: https://manual.audacityteam.org/man/error_opening_sound_device.html ... a variety of minor issues can cause this epic-looking problem (also some bigger problems, but hopefully it's just Windows in a tangle.)
There's honestly no such thing as a stupid question -- but I'm afraid I can't rule out giving a stupid answer : : To Posterity and Beyond!

GrayHouse
Posts: 447
Joined: October 6th, 2012, 3:27 pm

Post by GrayHouse » October 13th, 2018, 8:04 am

Check your Windows Permissions for the microphone:
Windows Button | Settings (gear icon)
select Privacy
select Microphone from the list on the left
check that it says Microphone access for this device is on. If it's not, use the Change button.

-Ian

Post Reply