Help requested with baffling microphone level problem

Post your questions & get help from friendly LibriVoxers
Post Reply
rogrossm
Posts: 3
Joined: December 5th, 2017, 7:13 am

Post by rogrossm » December 7th, 2017, 5:58 am

Hi everyone,

Just finished recording my first book, which was very amateurish but a great experience. I'm so excited about reading more audiobooks I invested in some equipment to get better sound quality, specifically a RODE NT1-A condenser microphone and a Focusrite Scarlett Solo audio interface.

I've been using ocenAudio to record in "punch and roll" mode. However the audio that is recorded gets clipped at -6 dB.

On the sound monitor, I can see the levels going all the way up to 0 dB, but the recorded waveform is always clipped. Here's a screenshot: http://i.imgur.com/mSlIXSY.png

This happens only with the new microphone. With my old USB microphone, it records the complete waveform with no clipping.

Any ideas why this might be happening, how I can stop this clipping?

aradlaw
LibriVox Admin Team
Posts: 12021
Joined: July 14th, 2008, 4:54 pm
Location: Nottawasaga Bay
Contact:

Post by aradlaw » December 7th, 2017, 7:46 am

The first thing that comes to mind is recording volume, the waveform you've posted looks too high.
A lot of folks here use Audacity, this is the advice we give regarding volume level...
You should aim for your wave forms to peak near the 0.5 mark, like this:
Image

You can check your volume using our Checker program - see info at http://wiki.librivox.org/index.php/Checker Make sure you download the experimental version - you will find the volume in decibels on the Information tab. For your information, we look for around 89 dB (87-91 is OK)

Please try our One minute Test to get feedback on your recording setup. :wink:
David Lawrence

* Weekly & Fortnightly Poetry - Check out the Short Works forum for the latest projects!

lurcherlover
Posts: 421
Joined: November 10th, 2016, 3:54 am
Location: LONDON UK

Post by lurcherlover » December 7th, 2017, 8:32 am

The Rode NT1A mic has quite a high output and very low noise. It requires 48 volt phantom power. I don't know anything about the interface you have. You will need to turn the gain control down - either on the interface or in software in the computer operating system - PC or Mac.

Your example linked was quite severely clipped and must sound quite distorted.

tovarisch
Posts: 1900
Joined: February 24th, 2013, 7:14 am
Location: New Hampshire, USA

Post by tovarisch » December 7th, 2017, 8:40 am

I have used two XLR-to-USB interfaces, and both pretty much never deliver the sample all the way to 0db. They scale their delivery to the computer at about -6 db. As lurcherlover says, make sure the gain is adjusted so that clipping does not happen - the interface may have a way to tell you (is there a red LED lighting up when you speak louder, on the interface itself?). You will likely need to amplify your track in post-processing, and that's normal for using audio interfaces with external audio sources.
tovarisch
  • reality prompts me to scale down my reading, sorry to say
    to PLers: do correct my pronunciation please

rogrossm
Posts: 3
Joined: December 5th, 2017, 7:13 am

Post by rogrossm » December 8th, 2017, 6:59 am

Hey everyone, thanks for the attempts to help. However I see I didn't explain the problem too well.

I realize the waveform I posted looks like the levels are set way too high because of the way it's clipped. But this is not the case.

Normally that kind of clipping occurs at 0 dB, and if you are seeing that then your levels are set too high. That's how the same setup behaves with my USB mic.

But in this case the waveform is getting clipped at -6 dB. That shouldn't happen.

Of course I could just set my recording level low enough to avoid the clipping, but that isn't how a mic like this is supposed to work. The sound should only get clipped above 0 dB, leaving the range below that for the actual recording, which normally never goes above -3 dB.

This seems to be either a software setting or an actual problem with the hardware, presumably the interface. I'm assuming it's a software setting but I can't find it for the life of me.

GrayHouse
Posts: 394
Joined: October 6th, 2012, 3:27 pm

Post by GrayHouse » December 8th, 2017, 7:11 am

I understand your problem, and I agree with you - it shouldn't behave like that.

My suggestion would be to try different recording software (maybe Audacity). If you can replicate the problem that would rule out the recording software. In which case I'd be inclined to take the problem to the technical support folks at Focusrite.

Best,
-Ian

tovarisch
Posts: 1900
Joined: February 24th, 2013, 7:14 am
Location: New Hampshire, USA

Post by tovarisch » December 8th, 2017, 8:35 am

It does not depend on the software that accepts audio input, I suspect. It depends on the driver that controls the device or maybe the internal circuitry of the device itself. The samples are limited on the device or in the driver, and the limited samples are sent from the driver to the software. Audacity gets them limited just as any other audio editor. At least that is so in my experience. :|

Of course, one should try other software to confirm, and, yes, speak to Focusrite folks... Be prepared that the result is going to be the same.
tovarisch
  • reality prompts me to scale down my reading, sorry to say
    to PLers: do correct my pronunciation please

GrayHouse
Posts: 394
Joined: October 6th, 2012, 3:27 pm

Post by GrayHouse » December 8th, 2017, 8:56 am

Yes, I'd expect the result to be the same too. But ruling out any possibility of strange interraction between the software and driver would demonstrate to the Focusrite people that it's 'their' problem. It looks so odd that I don't think it's going to be a simple setting, so I suspect the Focusrite people will be interested in hearing about it.

Let us know what you find...

ETA: rogrossm, it would be interesting to know how far round your gain knob is set...

lurcherlover
Posts: 421
Joined: November 10th, 2016, 3:54 am
Location: LONDON UK

Post by lurcherlover » December 13th, 2017, 1:42 am

Can you try a different mic? Borrow one?

It may mean you need an attenuator between the mic and the interface if another mic works fine. This could be a simple in circuit resistor.

Peter
Last edited by lurcherlover on December 14th, 2017, 6:03 am, edited 1 time in total.

MagicMan
Posts: 293
Joined: November 29th, 2017, 1:47 am
Location: Northern Va.

Post by MagicMan » December 14th, 2017, 3:15 am

rogrossm wrote:Hey everyone, thanks for the attempts to help. However I see I didn't explain the problem too well.

I realize the waveform I posted looks like the levels are set way too high because of the way it's clipped. But this is not the case.

Normally that kind of clipping occurs at 0 dB, and if you are seeing that then your levels are set too high. That's how the same setup behaves with my USB mic.
You have some very respected audio gear, it needs to be uses as intended by the manufacture.
But in this case the waveform is getting clipped at -6 dB. That shouldn't happen.
This is more then likely a software issue. In reaper, I can set my meters to show clipping at any level. I have mine set at a -3.5dbs. All this does is give me a warning, without actually clipping the audio. It just gives me an extra 3.5dbs of headroom.
Of course I could just set my recording level low enough to avoid the clipping, but that isn't how a mic like this is supposed to work. The sound should only get clipped above 0 dB, leaving the range below that for the actual recording, which normally never goes above -3 dB.
When using an audio interface, you want your input levels to be between a -12 and -18dbs. This is your best signal to noise ratio you can get with digital audio.
This seems to be either a software setting or an actual problem with the hardware, presumably the interface. I'm assuming it's a software setting but I can't find it for the life of me.
I have never herd of your editing software but, keep in mind that you now own a great package for recording audio. I would recommend you check Reaper out. Your AI has a dedicated ASIO file that most free or web browser recording programs can not read. Anyway, you may be able to contact the software developers here. https://www.ocenaudio.com/feedback

EDIT: I think your software has a pre-fx hard limiter applied, set at the -6db range. I was able to duplicate your issue using Reaper in the picture below. We call it the "Lawn Mower Effect". Notice the peaks in the pic below all cut off at the same level.

Image

Post Reply